#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#\s*(([^\n]*(\n|$))*?)(?=\n|#|<[uo]l>|\*|$)"
Local $sString = "* bullet" & @CRLF & _
"text on new line" & @CRLF & _
"more text" & @CRLF & _
"" & @CRLF & _
"this should be a separate block" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"* bullet" & @CRLF & _
"text on a new line" & @CRLF & _
"more text" & @CRLF & _
"" & @CRLF & _
"this should be a separate block"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")