import Foundation
let pattern = ##"#\s*(([^\n]*(\n|$))*?)(?=\n|#|<[uo]l>|\*|$)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
* bullet
text on new line
more text
this should be a separate block
* bullet
text on a new line
more text
this should be a separate block
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)