import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#\\s*(([^\\n]*(\\n|$))*?)(?=\\n|#|<[uo]l>|\\*|$)";
final String string = "* bullet\n"
+ "text on new line\n"
+ "more text\n\n"
+ "this should be a separate block\n\n\n"
+ "* bullet\n"
+ "text on a new line\n"
+ "more text\n\n"
+ "this should be a separate block";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}