using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#\s*(([^\n]*(\n|$))*?)(?=\n|#|<[uo]l>|\*|$)";
string input = @"* bullet
text on new line
more text
this should be a separate block
* bullet
text on a new line
more text
this should be a separate block";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}