re = /#\s*(([^\n]*(\n|$))*?)(?=\n|#|<[uo]l>|\*|$)/
str = '* bullet
text on new line
more text
this should be a separate block
* bullet
text on a new line
more text
this should be a separate block'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end