#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^path(?:(?=\?)(?:[?&]foo=(\d*)(?=[&#]|$)|(?![?&]foo=)[^#\n])+)?(?=#|$)"
Local $sString = "path" & @CRLF & _
"pathbreak" & @CRLF & _
"path?foo=123" & @CRLF & _
"path?foo=-123" & @CRLF & _
"invalid?foo=1" & @CRLF & _
"path?foo=123&bar=abc" & @CRLF & _
"path?bar=abc&foo=123" & @CRLF & _
"path?bar=foo" & @CRLF & _
"path#anchor" & @CRLF & _
"path#foo=bar" & @CRLF & _
"path?foo=123#bar" & @CRLF & _
"path?foo=123abc" & @CRLF & _
"path?foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")