import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^path(?:(?=\\?)(?:[?&]foo=(\\d*)(?=[&#]|$)|(?![?&]foo=)[^#\\n])+)?(?=#|$)";
final String string = "path\n"
+ "pathbreak\n"
+ "path?foo=123\n"
+ "path?foo=-123\n"
+ "invalid?foo=1\n"
+ "path?foo=123&bar=abc\n"
+ "path?bar=abc&foo=123\n"
+ "path?bar=foo\n"
+ "path#anchor\n"
+ "path#foo=bar\n"
+ "path?foo=123#bar\n"
+ "path?foo=123abc\n"
+ "path?foo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}