use strict;
my $str = 'path
pathbreak
path?foo=123
path?foo=-123
invalid?foo=1
path?foo=123&bar=abc
path?bar=abc&foo=123
path?bar=foo
path#anchor
path#foo=bar
path?foo=123#bar
path?foo=123abc
path?foo';
my $regex = qr/^path(?:(?=\?)(?:[?&]foo=(\d*)(?=[&#]|$)|(?![?&]foo=)[^#\n])+)?(?=#|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}