const regex = /^path(?:(?=\?)(?:[?&]foo=(\d*)(?=[&#]|$)|(?![?&]foo=)[^#\n])+)?(?=#|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^path(?:(?=\\?)(?:[?&]foo=(\\d*)(?=[&#]|$)|(?![?&]foo=)[^#\\n])+)?(?=#|$)', 'gm')
const str = `path
pathbreak
path?foo=123
path?foo=-123
invalid?foo=1
path?foo=123&bar=abc
path?bar=abc&foo=123
path?bar=foo
path#anchor
path#foo=bar
path?foo=123#bar
path?foo=123abc
path?foo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}