package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*,)`)
var str = `1, 2, 3, 4`
var substitution = "$1 and"
fmt.Println(re.ReplaceAllString(str, substitution))
}