use strict;
my $str = '1, 2, 3, 4';
my $regex = qr/(.*,)/mp;
my $subst = '$1 and';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";