$re = '/(.*,)/m';
$str = '1, 2, 3, 4';
$subst = "$1 and";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;