const regex = /(.*,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*,)', 'gm')
const str = `1, 2, 3, 4`;
const subst = `$1 and`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);