import re
regex = re.compile(r"(.*,)", flags=re.MULTILINE)
test_str = "1, 2, 3, 4"
subst = "$1 and"
result = regex.sub(subst, test_str)
if result:
print(result)