#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[^0-9]|^)(0)(?:[^0-9]|$)"
Local $sString = "0fdsfdsfdsf0fdsfdsf0fd00dsdas000dsadsa00000000000000dsadsa" & @CRLF & _
"00dsads000dsadsa45ds02ds2a0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")