$re = '/(?:[^0-9]|^)(0)(?:[^0-9]|$)/';
$str = '0fdsfdsfdsf0fdsfdsf0fd00dsdas000dsadsa00000000000000dsadsa
00dsads000dsadsa45ds02ds2a0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);