package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^0-9]|^)(0)(?:[^0-9]|$)`)
var str = `0fdsfdsfdsf0fdsfdsf0fd00dsdas000dsadsa00000000000000dsadsa
00dsads000dsadsa45ds02ds2a0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}