using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^0-9]|^)(0)(?:[^0-9]|$)";
string input = @"0fdsfdsfdsf0fdsfdsf0fd00dsdas000dsadsa00000000000000dsadsa
00dsads000dsadsa45ds02ds2a0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}