re = /(?:[^0-9]|^)(0)(?:[^0-9]|$)/
str = '0fdsfdsfdsf0fdsfdsf0fd00dsdas000dsadsa00000000000000dsadsa
00dsads000dsadsa45ds02ds2a0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end