using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(.*\{\{while\s+.*(?:\r?\n.*)+\{\{while\s+end.*)";
string substitution = @"$1";
string input = @"<html lang=""{{var doc-lang}}"">
<head>
<title>{{var doc-title}}</div>
</head>
<body>
<div class=""container"">
<div class=""row"" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}