use strict;
my $str = '<html lang="{{var doc-lang}}">
<head>
<title>{{var doc-title}}</div>
</head>
<body>
<div class="container">
<div class="row" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>';
my $regex = qr/\s*(.*\{\{while\s+.*(?:\r?\n.*)+\{\{while\s+end.*)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";