re = /\s*(.*\{\{while\s+.*(?:\r?\n.*)+\{\{while\s+end.*)/
str = '<html lang="{{var doc-lang}}">
<head>
<title>{{var doc-title}}</div>
</head>
<body>
<div class="container">
<div class="row" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result