package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(.*\{\{while\s+.*(?:\r?\n.*)+\{\{while\s+end.*)`)
var str = []byte(`<html lang="{{var doc-lang}}">
<head>
<title>{{var doc-title}}</div>
</head>
<body>
<div class="container">
<div class="row" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>`)
var substitution = []byte("$1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}