#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\"[^\"]*[\u2E80-\u9FFF]+[^\"]*\""
Local $sString = "// case ph_text_fill_item:" & @CRLF & _
"// v[TEST_TYPE_TEXT] = W2U(L"填空题");" & @CRLF & _
"// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);" & @CRLF & _
"// break;" & @CRLF & _
"// case ph_text_answer_fill_item:" & @CRLF & _
"// v[TEST_TYPE_TEXT] = W2U(L"解答题");" & @CRLF & _
"// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);" & @CRLF & _
"// break;" & @CRLF & _
"// case ph_text_answer_trueorfalse:" & @CRLF & _
"// v[TEST_TYPE_TEXT] = W2U(L"判断题");" & @CRLF & _
"// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")