// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"[^\"]*[\u2E80-\u9FFF]+[^\"]*\""#).unwrap();
let string = "// case ph_text_fill_item:
// v[TEST_TYPE_TEXT] = W2U(L\"填空题\");
// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);
// break;
// case ph_text_answer_fill_item:
// v[TEST_TYPE_TEXT] = W2U(L\"解答题\");
// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);
// break;
// case ph_text_answer_trueorfalse:
// v[TEST_TYPE_TEXT] = W2U(L\"判断题\");
// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}