#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Html->script|cell|element|Html->css)\(([^\)]+)\)"
Local $sString = "$this->element('element.ctp');" & @CRLF & _
"$this->cell('teste.ctp');" & @CRLF & _
"$this->Html->script([" & @CRLF & _
" 'teste.js'" & @CRLF & _
"]);" & @CRLF & _
"$this->Html->script([" & @CRLF & _
" 'teste.js'," & @CRLF & _
" 'teste2.js'," & @CRLF & _
"]);" & @CRLF & _
"$this->Html->script(['teste.js']);" & @CRLF & _
"$this->Html->script('teste.js');" & @CRLF & _
"$this->Html->css(['teste.css']);" & @CRLF & _
"$this->Html->css('teste.css');"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")