use strict;
my $str = '$this->element(\'element.ctp\');
$this->cell(\'teste.ctp\');
$this->Html->script([
\'teste.js\'
]);
$this->Html->script([
\'teste.js\',
\'teste2.js\',
]);
$this->Html->script([\'teste.js\']);
$this->Html->script(\'teste.js\');
$this->Html->css([\'teste.css\']);
$this->Html->css(\'teste.css\');';
my $regex = qr/(?<=Html->script|cell|element|Html->css)\(([^\)]+)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}