$re = '/(?<=Html->script|cell|element|Html->css)\(([^\)]+)\)/m';
$str = '$this->element(\'element.ctp\');
$this->cell(\'teste.ctp\');
$this->Html->script([
\'teste.js\'
]);
$this->Html->script([
\'teste.js\',
\'teste2.js\',
]);
$this->Html->script([\'teste.js\']);
$this->Html->script(\'teste.js\');
$this->Html->css([\'teste.css\']);
$this->Html->css(\'teste.css\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);