using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Html->script|cell|element|Html->css)\(([^\)]+)\)";
string input = @"$this->element('element.ctp');
$this->cell('teste.ctp');
$this->Html->script([
'teste.js'
]);
$this->Html->script([
'teste.js',
'teste2.js',
]);
$this->Html->script(['teste.js']);
$this->Html->script('teste.js');
$this->Html->css(['teste.css']);
$this->Html->css('teste.css');";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}