re = /(?<=Html->script|cell|element|Html->css)\(([^\)]+)\)/m
str = '$this->element(\'element.ctp\');
$this->cell(\'teste.ctp\');
$this->Html->script([
\'teste.js\'
]);
$this->Html->script([
\'teste.js\',
\'teste2.js\',
]);
$this->Html->script([\'teste.js\']);
$this->Html->script(\'teste.js\');
$this->Html->css([\'teste.css\']);
$this->Html->css(\'teste.css\');'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end