#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?!.*\b(?:the|ones|that|should|not|match)\b)(?=.*\b(?:words|I|want|to|include)\b).*$"
Local $sString = "Words I know" & @CRLF & _
"Words that I know" & @CRLF & _
"I want to watch this" & @CRLF & _
"I want to watch that" & @CRLF & _
"To include everyone" & @CRLF & _
"To include the ones" & @CRLF & _
"He wants ice-cream (doesn't m@tch as "wants" != "w@nt")" & @CRLF & _
"We want to see him include" & @CRLF & _
"We want to see him include that option"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")