$re = '/^(?!.*\b(?:the|ones|that|should|not|match)\b)(?=.*\b(?:words|I|want|to|include)\b).*$/im';
$str = 'Words I know
Words that I know
I want to watch this
I want to watch that
To include everyone
To include the ones
He wants ice-cream (doesn\'t m@tch as "wants" != "w@nt")
We want to see him include
We want to see him include that option';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);