using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\b(?:the|ones|that|should|not|match)\b)(?=.*\b(?:words|I|want|to|include)\b).*$";
string input = @"Words I know
Words that I know
I want to watch this
I want to watch that
To include everyone
To include the ones
He wants ice-cream (doesn't m@tch as ""wants"" != ""w@nt"")
We want to see him include
We want to see him include that option";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}