import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\b(?:the|ones|that|should|not|match)\\b)(?=.*\\b(?:words|I|want|to|include)\\b).*$";
final String string = "Words I know\n"
+ "Words that I know\n"
+ "I want to watch this\n"
+ "I want to watch that\n"
+ "To include everyone\n"
+ "To include the ones\n"
+ "He wants ice-cream (doesn't m@tch as \"wants\" != \"w@nt\")\n"
+ "We want to see him include\n"
+ "We want to see him include that option";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}