#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "var (?:(?!var).)*?=function.*11"
Local $sString = "var abc1=function(_x1,_y1){var a=1,b=2,c=3};var abc2=function(_x2,_y2){var a=4,b=5,c=6};var abc3=function(_x3,_y3){var a=7,b=8,c=9};var abc4=function(_x4,_y4){var a=10,b=11,c=12};var abc5=function(_x5,_y5){var a=13,b=14,c=15}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")