const regex = /var (?:(?!var).)*?=function.*11/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('var (?:(?!var).)*?=function.*11', 'g')
const str = `var abc1=function(_x1,_y1){var a=1,b=2,c=3};var abc2=function(_x2,_y2){var a=4,b=5,c=6};var abc3=function(_x3,_y3){var a=7,b=8,c=9};var abc4=function(_x4,_y4){var a=10,b=11,c=12};var abc5=function(_x5,_y5){var a=13,b=14,c=15}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}