import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "var (?:(?!var).)*?=function.*11";
final String string = "var abc1=function(_x1,_y1){var a=1,b=2,c=3};var abc2=function(_x2,_y2){var a=4,b=5,c=6};var abc3=function(_x3,_y3){var a=7,b=8,c=9};var abc4=function(_x4,_y4){var a=10,b=11,c=12};var abc5=function(_x5,_y5){var a=13,b=14,c=15}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}