using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"var (?:(?!var).)*?=function.*11";
string input = @"var abc1=function(_x1,_y1){var a=1,b=2,c=3};var abc2=function(_x2,_y2){var a=4,b=5,c=6};var abc3=function(_x3,_y3){var a=7,b=8,c=9};var abc4=function(_x4,_y4){var a=10,b=11,c=12};var abc5=function(_x5,_y5){var a=13,b=14,c=15}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}