package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\d*$|^(?:\d{1,3}(?:\.\d{3})*(?:,\d{1,5})?)$|^(?:\d{1,3}(?:,\d{3})*(?:\.\d{1,5})?)$|^(?:\d{1,3}(?: \d{3})*(?:[,.]\d{1,5})?)$`)
var str = `123
1.234.567
12.345.678
123.456.789
1.234.567,89
1.234,56789
1,2
0,123
1,234,567
12,345,678
123,456,789
1,234,567.89
1,234.56789
1.2
0.123
1 234 567
12 345 678
123 456 789
1 234 567,89
1 234 567.89
1 234,56789
1 234.56789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}