use strict;
my $str = '123
1.234.567
12.345.678
123.456.789
1.234.567,89
1.234,56789
1,2
0,123
1,234,567
12,345,678
123,456,789
1,234,567.89
1,234.56789
1.2
0.123
1 234 567
12 345 678
123 456 789
1 234 567,89
1 234 567.89
1 234,56789
1 234.56789';
my $regex = qr/^\d*$|^(?:\d{1,3}(?:\.\d{3})*(?:,\d{1,5})?)$|^(?:\d{1,3}(?:,\d{3})*(?:\.\d{1,5})?)$|^(?:\d{1,3}(?: \d{3})*(?:[,.]\d{1,5})?)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}