const regex = /^\d*$|^(?:\d{1,3}(?:\.\d{3})*(?:,\d{1,5})?)$|^(?:\d{1,3}(?:,\d{3})*(?:\.\d{1,5})?)$|^(?:\d{1,3}(?: \d{3})*(?:[,.]\d{1,5})?)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d*$|^(?:\\d{1,3}(?:\\.\\d{3})*(?:,\\d{1,5})?)$|^(?:\\d{1,3}(?:,\\d{3})*(?:\\.\\d{1,5})?)$|^(?:\\d{1,3}(?: \\d{3})*(?:[,.]\\d{1,5})?)$', 'gmi')
const str = `123
1.234.567
12.345.678
123.456.789
1.234.567,89
1.234,56789
1,2
0,123
1,234,567
12,345,678
123,456,789
1,234,567.89
1,234.56789
1.2
0.123
1 234 567
12 345 678
123 456 789
1 234 567,89
1 234 567.89
1 234,56789
1 234.56789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}