import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d*$|^(?:\\d{1,3}(?:\\.\\d{3})*(?:,\\d{1,5})?)$|^(?:\\d{1,3}(?:,\\d{3})*(?:\\.\\d{1,5})?)$|^(?:\\d{1,3}(?: \\d{3})*(?:[,.]\\d{1,5})?)$";
final String string = "123\n"
+ "1.234.567\n"
+ "12.345.678\n"
+ "123.456.789\n"
+ "1.234.567,89\n"
+ "1.234,56789\n"
+ "1,2\n"
+ "0,123\n"
+ "1,234,567\n"
+ "12,345,678\n"
+ "123,456,789\n"
+ "1,234,567.89\n"
+ "1,234.56789\n"
+ "1.2\n"
+ "0.123\n"
+ "1 234 567\n"
+ "12 345 678\n"
+ "123 456 789\n"
+ "1 234 567,89\n"
+ "1 234 567.89\n"
+ "1 234,56789\n"
+ "1 234.56789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}