re = /^\d*$|^(?:\d{1,3}(?:\.\d{3})*(?:,\d{1,5})?)$|^(?:\d{1,3}(?:,\d{3})*(?:\.\d{1,5})?)$|^(?:\d{1,3}(?: \d{3})*(?:[,.]\d{1,5})?)$/mi
str = '123
1.234.567
12.345.678
123.456.789
1.234.567,89
1.234,56789
1,2
0,123
1,234,567
12,345,678
123,456,789
1,234,567.89
1,234.56789
1.2
0.123
1 234 567
12 345 678
123 456 789
1 234 567,89
1 234 567.89
1 234,56789
1 234.56789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end