package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]:\\(?:[^\\\n]*\\)*([^\\\n]+)\\([^\\\n]+)$`)
var str = `C:\Program Files\nodejs\node_modules
C:\nodejs\node_modules
C:\Program Files\test\nodejs\node_modules
`
var substitution = "http:s//$1/$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}