const regex = /^[A-Z]:\\(?:[^\\\n]*\\)*([^\\\n]+)\\([^\\\n]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]:\\\\(?:[^\\\\\\n]*\\\\)*([^\\\\\\n]+)\\\\([^\\\\\\n]+)$', 'gm')
const str = `C:\\Program Files\\nodejs\\node_modules
C:\\nodejs\\node_modules
C:\\Program Files\\test\\nodejs\\node_modules
`;
const subst = `http:s//$1/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);