import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]:\\\\(?:[^\\\\\\n]*\\\\)*([^\\\\\\n]+)\\\\([^\\\\\\n]+)$";
final String string = "C:\\Program Files\\nodejs\\node_modules\n"
+ "C:\\nodejs\\node_modules\n"
+ "C:\\Program Files\\test\\nodejs\\node_modules\n";
final String subst = "http:s//$1/$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}