re = /^[A-Z]:\\(?:[^\\\n]*\\)*([^\\\n]+)\\([^\\\n]+)$/m
str = 'C:\\Program Files\\nodejs\\node_modules
C:\\nodejs\\node_modules
C:\\Program Files\\test\\nodejs\\node_modules
'
subst = 'http:s//$1/$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result