#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<tr[^>]*>((?!<\/tr>|<td>|<\/td>).)*<\/tr>"
Local $sString = "<tr asdf>" & @CRLF & _
"<td>" & @CRLF & _
"<hello>" & @CRLF & _
"</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr asdf>" & @CRLF & _
"</tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")