$re = '/<tr[^>]*>((?!<\/tr>|<td>|<\/td>).)*<\/tr>/s';
$str = '<tr asdf>
<td>
<hello>
</td>
</tr>
<tr asdf>
</tr>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);