re = /<tr[^>]*>((?!<\/tr>|<td>|<\/td>).)*<\/tr>/
str = '<tr asdf>
<td>
<hello>
</td>
</tr>
<tr asdf>
</tr>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end